What’s Vulnerable › Vulnerabilities
CVE-2026-10622: CVE-2026-10622
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-02 · updated 2026-07-22
Description
Improper Authentication in REST API in Collibra Agent, allows a remote unauthenticated attacker to access privileged functionality via exposed '/rest/* endpoints.
Affected products
- Collibra Platform (on-prem): from 2026.03 before 2026.03.356; from 2025.10 before 2025.10.399 — fixed in 2025.10.399, 2026.03.356
- Collibra Platform (SaaS): from 2026.04 before 2026.04.5; from 2026.03 before 2026.03.4; from 2026.02 before 2026.02.6; from 2025.11 before 2025.11.7; from 2025.10 before 2025.10.9 — fixed in 2025.10.9, 2025.11.7, 2026.02.6, 2026.03.4, 2026.04.5
How to fix
Upgrade to a fixed version: Collibra Platform (on-prem) 2025.10.399, 2026.03.356; Collibra Platform (SaaS) 2025.10.9, 2025.11.7, 2026.02.6, 2026.03.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-10622 or the next vulnerability affects your stack