What’s Vulnerable › Vulnerabilities
CVE-2026-106443: WeasyPrint: EPS images reach the Ghostscript interpreter resulting in RCE
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-06 · updated 2026-10-06
- Weakness: CWE-20
Description
WeasyPrint helps web developers to create PDF documents. Prior to 70.0, the image-loading path in weasyprint/images.py passes fetched image bytes from HTML img URLs, CSS image values, SVG image references, and data URIs to Pillow's generic image dispatcher without excluding EPS or PostScript formats. On hosts with Ghostscript installed, Pillow EpsImagePlugin invokes the interpreter for attacker-controlled PostScript, which can produce interpreter-permitted effects and can lead to remote code execution when the installed Ghostscript version has a usable sandbox bypass. Hosts without Ghostscript do not reach this rasterization path. This issue is fixed in version 70.0.
Affected products
- Kozea WeasyPrint: before 70.0
References
- https://github.com/Kozea/WeasyPrint/commit/39cd37ce1610bd890388e26591c569db1cbab542
- https://github.com/Kozea/WeasyPrint/releases/tag/v70.0
- https://github.com/Kozea/WeasyPrint/security/advisories/GHSA-r543-q48m-4c9j
Get alerted when CVE-2026-106443 or the next vulnerability affects your stack