What’s Vulnerable › Vulnerabilities
CVE-2026-106455: Backstage: Improper validation of MkDocs plugin configuration in TechDocs
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-06 · updated 2026-10-13
- Weakness: CWE-918
Description
Backstage is an open framework for building developer portals. From 0.11.12 until 1.14.7 and 1.15.5, the @backstage/plugin-techdocs-node package is affected by improper validation of mkdocs plugin configuration in techdocs. An authenticated attacker with control over a TechDocs source repository could cause a documentation build to retrieve and publish data from network locations reachable by the build environment. Exposure depends on deployment topology, build mode, and target endpoint protections. Modern cloud metadata services that require tokens or special headers are not directly accessible through the affected behavior. This issue is fixed in @backstage/plugin-techdocs-node versions 1.14.7 and 1.15.5.
Affected products
- backstage: from 0.71.1 before 1.50.6; from 1.51.1 before 1.54.8; 1.51.0, 1.51.0-next0, 1.51.0-next1, 1.51.0-next2, 1.51.0-next3 — fixed in 1.50.6, 1.54.8
- Linuxfoundation Backstage Plugin-Techdocs-Node: from 0.11.12 before 1.14.7; from 1.15.0 before 1.15.5 — fixed in 1.14.7, 1.15.5
How to fix
Upgrade to a fixed version: backstage 1.50.6, 1.54.8; Linuxfoundation Backstage Plugin-Techdocs-Node 1.14.7, 1.15.5. Check the vendor advisory for mitigations.
References
- https://github.com/backstage/backstage/commit/28aa82ae2815988721dd7bbf43cd69c431dcd71b
- https://github.com/backstage/backstage/commit/9f76ea445088961f68c364764cc4b7734f368fc0
- https://github.com/backstage/backstage/releases/tag/v1.50.6
- https://github.com/backstage/backstage/releases/tag/v1.54.8
- https://github.com/backstage/backstage/releases/tag/v1.55.0
- https://github.com/backstage/backstage/security/advisories/GHSA-q38j-6vcm-2f5m
Get alerted when CVE-2026-106455 or the next vulnerability affects your stack