What’s Vulnerable › Vulnerabilities
CVE-2026-106456: Backstage: Inconsistent credential enforcement for overlapping proxy routes
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-06 · updated 2026-10-27
- Weakness: CWE-863
Description
Backstage is an open framework for building developer portals. From 0.5.0 until 0.6.18, the @backstage/plugin-proxy-backend package is affected by inconsistent credential enforcement for overlapping proxy routes. An operator can configure overlapping proxy paths with different credential requirements. When a parent path permits unauthenticated access and a nested path requires credentials, the parent exemption can also cover requests handled by the nested proxy. An unauthenticated caller may therefore reach the nested upstream through Backstage, including with static upstream credentials configured for that proxy. This issue is fixed in version 0.6.18.
Affected products
- backstage: from 1.28.0 before 1.55.0 — fixed in 1.55.0
- Linuxfoundation Backstage/Plugin-Proxy-Backend: from 0.5.0 before 0.6.18 — fixed in 0.6.18
- backstage: from 1.28.0, < 1.55.0
- @backstage plugin-proxy-backend: from 0.5.0, < 0.6.18
How to fix
Upgrade to a fixed version: backstage 1.55.0; Linuxfoundation Backstage/Plugin-Proxy-Backend 0.6.18. Check the vendor advisory for mitigations.
References
- https://github.com/backstage/backstage/commit/9df92923ac32558bb80edeceafd8de780c44e218
- https://github.com/backstage/backstage/releases/tag/v1.55.0
- https://github.com/backstage/backstage/security/advisories/GHSA-472h-9c5j-prrr
Get alerted when CVE-2026-106456 or the next vulnerability affects your stack