What’s Vulnerable › Vulnerabilities
CVE-2026-106459: Backstage: Improper input validation in Sentry scaffolder actions
- Severity: high (CVSS 8.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-06 · updated 2026-10-13
- Weakness: CWE-200
Description
Backstage is an open framework for building developer portals. From 0.3.0 until 0.3.8, the @backstage/plugin-scaffolder-backend-module-sentry package is affected by improper input validation in sentry scaffolder actions. An authenticated internal user who can execute the affected actions may cause the backend to contact unintended destinations and disclose Sentry integration credentials. Subsequent impact depends on network reachability and the privileges granted to the configured token. This issue is fixed in version 0.3.8.
Affected products
- backstage: from 1.47.0 before 1.54.8 — fixed in 1.54.8
- Linuxfoundation Backstage/Plugin-Scaffolder-Backend-Module-Sentry: from 0.3.0 before 0.3.8 — fixed in 0.3.8
How to fix
Upgrade to a fixed version: backstage 1.54.8; Linuxfoundation Backstage/Plugin-Scaffolder-Backend-Module-Sentry 0.3.8. Check the vendor advisory for mitigations.
References
- https://github.com/backstage/backstage/commit/b0170fad7962fb8c3d71366b5265cf283c7bbcf7
- https://github.com/backstage/backstage/releases/tag/v1.54.8
- https://github.com/backstage/backstage/releases/tag/v1.55.0
- https://github.com/backstage/backstage/security/advisories/GHSA-g734-fhp4-7mfp
Get alerted when CVE-2026-106459 or the next vulnerability affects your stack