What’s Vulnerable › Vulnerabilities
CVE-2026-106488: Backstage: Improper authentication in the OIDC provider
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-06 · updated 2026-10-22
- Weakness: CWE-287
Description
Backstage is an open framework for building developer portals. Prior to 0.4.20, the @backstage/plugin-auth-backend-module-oidc-provider package is affected by improper authentication in the oidc provider. Deployments using OIDC email-based identity resolution with a provider that permits unverified email addresses may allow an authenticated provider user to assume another catalog identity. This may grant access and permissions associated with that user. No direct availability impact is demonstrated. This issue is fixed in version 0.4.20.
Affected products
- backstage: before 1.54.6 — fixed in 1.54.6
- Linuxfoundation Backstage/Plugin-Auth-Backend-Module-Oidc-Provider: before 0.4.20 — fixed in 0.4.20
How to fix
Upgrade to a fixed version: backstage 1.54.6; Linuxfoundation Backstage/Plugin-Auth-Backend-Module-Oidc-Provider 0.4.20. Check the vendor advisory for mitigations.
References
- https://github.com/backstage/backstage/commit/1b1f05e82161aaabc226c1d7d498d746956bf942
- https://github.com/backstage/backstage/releases/tag/v1.54.6
- https://github.com/backstage/backstage/security/advisories/GHSA-826h-28h9-65hg
Get alerted when CVE-2026-106488 or the next vulnerability affects your stack