What’s Vulnerable › Vulnerabilities
CVE-2026-106491: Backstage: Improper input validation in proxy-backend
- Severity: medium (CVSS 6.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-06 · updated 2026-10-22
- Weakness: CWE-20
Description
Backstage is an open framework for building developer portals. Prior to 0.6.17, the @backstage/plugin-proxy-backend package is affected by improper input validation in proxy-backend. An authenticated Backstage user could craft a request URL that causes the proxy-backend to forward the request to a path outside the configured base path on the target server. This is limited to target servers already configured as proxy endpoints and requires Backstage authentication by default. This issue is fixed in version 0.6.17.
Affected products
- backstage: before 1.54.6 — fixed in 1.54.6
- Linuxfoundation Backstage/Plugin-Proxy-Backend: before 0.6.17 — fixed in 0.6.17
How to fix
Upgrade to a fixed version: backstage 1.54.6; Linuxfoundation Backstage/Plugin-Proxy-Backend 0.6.17. Check the vendor advisory for mitigations.
References
- https://github.com/backstage/backstage/commit/233287d0ce3133e41549bf92a7470c940a41753c
- https://github.com/backstage/backstage/releases/tag/v1.54.6
- https://github.com/backstage/backstage/security/advisories/GHSA-9ghw-48h5-v2w5
Get alerted when CVE-2026-106491 or the next vulnerability affects your stack