What’s Vulnerable › Vulnerabilities
CVE-2026-106493: Backstage: Cloud storage catalog locations may cross configured storage boundaries
- Severity: medium (CVSS 4.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-06 · updated 2026-10-22
- Weakness: CWE-22
Description
Backstage is an open framework for building developer portals. Prior to 1.54.6, cloud storage catalog providers did not sufficiently validate object paths. A principal able to create or rename objects in a configured Azure Blob Storage or AWS S3 catalog source could cause catalog descriptors to be read from outside the intended storage boundary, limited to locations reachable with the backend's configured credentials. This issue is fixed in 1.54.6.
Affected products
- backstage: before 1.54.6 — fixed in 1.54.6
- Linuxfoundation Backstage/Backend-Defaults: before 0.17.8 — fixed in 0.17.8
- Linuxfoundation Backstage/Plugin-Catalog-Backend-Module-Aws: before 0.4.27 — fixed in 0.4.27
- Linuxfoundation Backstage/Plugin-Catalog-Backend-Module-Azure: before 0.3.21 — fixed in 0.3.21
How to fix
Upgrade to a fixed version: backstage 1.54.6; Linuxfoundation Backstage/Backend-Defaults 0.17.8; Linuxfoundation Backstage/Plugin-Catalog-Backend-Module-Aws 0.4.27; Linuxfoundation Backstage/Plugin-Catalog-Backend-Module-Azure 0.3.21. Check the vendor advisory for mitigations.
References
- https://github.com/backstage/backstage/commit/47ddbd8b4a3efd812309f759c38f4877fbd9e5ff
- https://github.com/backstage/backstage/releases/tag/v1.54.6
- https://github.com/backstage/backstage/security/advisories/GHSA-xvh9-35w9-42m4
Get alerted when CVE-2026-106493 or the next vulnerability affects your stack