What’s Vulnerable › Vulnerabilities

CVE-2026-106498: Backstage: Improper URL validation in catalog entity placeholder resolution

Description

Backstage is an open framework for building developer portals. Prior to 3.5.1, 3.6.2, 3.7.2, 3.8.2 and 3.9.1, the @backstage/plugin-catalog-backend package is affected by improper url validation in catalog entity placeholder resolution. An authenticated Backstage user could craft a catalog entity with placeholder directives that reference resources outside the entity's source repository. Under certain configurations, this could allow access to data not intended to be available to the user. This issue is fixed in versions 3.5.1, 3.6.2, 3.7.2, 3.8.2 and 3.9.1.

Affected products

How to fix

Upgrade to a fixed version: backstage 1.49.6, 1.50.5, 1.51.3, 1.53.2; Linuxfoundation Backstage Plugin-Catalog-Backend 3.5.1, 3.6.2, 3.7.2, 3.8.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-106498 or the next vulnerability affects your stack