What’s Vulnerable › Vulnerabilities
CVE-2026-106503: Backstage: Scaffolder action input authorization bypass
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-06 · updated 2026-10-13
- Weakness: CWE-178
Description
Backstage is an open framework for building developer portals. Prior to 3.3.1, 3.4.1, 4.0.3 and 4.1.0, the @backstage/plugin-scaffolder-backend package is affected by scaffolder action input authorization bypass. An authenticated user with access to affected Scaffolder templates could bypass configured action restrictions. Depending on integration credentials, this could grant unauthorized access to repositories and related source-control resources. This issue is fixed in versions 3.3.1, 3.4.1, 4.0.3 and 4.1.0.
Affected products
- backstage: before 1.49.6; from 1.50.0 before 1.50.5; from 1.51.0 before 1.54.6 — fixed in 1.49.6, 1.50.5, 1.54.6
- @backstage plugin-scaffolder-backend: before 3.3.1; from 3.4.0 before 3.4.1; from 4.0.0 before 4.0.3; from 4.0.4 before 4.1.0 — fixed in 3.3.1, 3.4.1, 4.0.3, 4.1.0
How to fix
Upgrade to a fixed version: backstage 1.49.6, 1.50.5, 1.54.6; @backstage plugin-scaffolder-backend 3.3.1, 3.4.1, 4.0.3, 4.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/backstage/backstage/commit/11c1384c0649b8ab26391c6a4e4f34b80ab0d188
- https://github.com/backstage/backstage/commit/a91ed72d540e80b62a73b39bb1563ff5018d52d1
- https://github.com/backstage/backstage/commit/e307e4f487103d815e484291b3fda778ab9983bf
- https://github.com/backstage/backstage/releases/tag/v1.49.6
- https://github.com/backstage/backstage/releases/tag/v1.50.5
- https://github.com/backstage/backstage/releases/tag/v1.54.6
- https://github.com/backstage/backstage/security/advisories/GHSA-hmp2-4m7g-22cv
Get alerted when CVE-2026-106503 or the next vulnerability affects your stack