What’s Vulnerable › Vulnerabilities
CVE-2026-106556: Backstage: Configuration bypass in TechDocs mkdocs.yml sanitization
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-07 · updated 2026-10-13
- Weakness: CWE-78
Description
Backstage is an open framework for building developer portals. Prior to 1.14.6, the @backstage/plugin-techdocs-node package is affected by configuration bypass in techdocs mkdocs.yml sanitization. Insufficient validation of MkDocs configuration during TechDocs generation could allow an authenticated user who can register or modify documentation sources to execute arbitrary commands in the build environment. Impact is limited to resources accessible to the TechDocs backend or build container. This issue is fixed in versions 1.14.6 and 1.15.4.
Affected products
- backstage: before 1.50.5; from 1.51.1 before 1.54.6; 1.51.0, 1.51.0-next0, 1.51.0-next1, 1.51.0-next2, 1.51.0-next3 — fixed in 1.50.5, 1.54.6
- Linuxfoundation Backstage Plugin-Techdocs-Node: before 1.14.6; from 1.15.0 before 1.15.4 — fixed in 1.14.6, 1.15.4
How to fix
Upgrade to a fixed version: backstage 1.50.5, 1.54.6; Linuxfoundation Backstage Plugin-Techdocs-Node 1.14.6, 1.15.4. Check the vendor advisory for mitigations.
References
- https://github.com/backstage/backstage/commit/25125ee727a3de3418a8fa6a9e458cd5b73ecf26
- https://github.com/backstage/backstage/commit/b6d1aea0bef99b8dfec3c8746032474867ba677a
- https://github.com/backstage/backstage/releases/tag/v1.50.5
- https://github.com/backstage/backstage/releases/tag/v1.54.6
- https://github.com/backstage/backstage/security/advisories/GHSA-g2hj-v2j6-vfvg
Get alerted when CVE-2026-106556 or the next vulnerability affects your stack