What’s Vulnerable › Vulnerabilities
CVE-2026-106559: Backstage: Improper input validation in Confluence to Markdown scaffolder module
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-07 · updated 2026-10-16
- Weakness: CWE-22
Description
Backstage is an open framework for building developer portals. Prior to 0.3.25, the @backstage/plugin-scaffolder-backend-module-confluence-to-markdown package is affected by improper input validation in confluence to markdown scaffolder module. Insufficient input validation in the Confluence to Markdown scaffolder module could allow an attacker to influence file write operations during template execution. Exploitation requires a Backstage user to run a template that processes attacker-influenced Confluence content. This issue is fixed in version 0.3.25.
Affected products
- backstage: before 1.54.6 — fixed in 1.54.6
- Linuxfoundation Backstage/Plugin-Scaffolder-Backend-Module-Confluence-To-Markdown: before 0.3.25 — fixed in 0.3.25
How to fix
Upgrade to a fixed version: backstage 1.54.6; Linuxfoundation Backstage/Plugin-Scaffolder-Backend-Module-Confluence-To-Markdown 0.3.25. Check the vendor advisory for mitigations.
References
- https://github.com/backstage/backstage/commit/506c2c11bce3ed9d1f8f50de5d6474b16e43a65e
- https://github.com/backstage/backstage/releases/tag/v1.54.6
- https://github.com/backstage/backstage/security/advisories/GHSA-75qf-886x-5xf2
Get alerted when CVE-2026-106559 or the next vulnerability affects your stack