What’s Vulnerable › Vulnerabilities
CVE-2026-106563: Backstage: Improper entity validation in deprecated Kubernetes services endpoint
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-07 · updated 2026-10-16
- Weakness: CWE-20
Description
Backstage is an open framework for building developer portals. Prior to 0.21.8, the @backstage/plugin-kubernetes-backend package is affected by improper entity validation in deprecated kubernetes services endpoint. An authenticated user with Kubernetes read permissions could access Kubernetes workload data beyond their intended scope by supplying crafted entity data to the deprecated services endpoint. The exposure is limited to read-only access to Kubernetes object metadata across configured clusters. This issue is fixed in version 0.21.8.
Affected products
- backstage: before 1.54.1 — fixed in 1.54.1
- Linuxfoundation Backstage/Plugin-Kubernetes-Backend: before 0.21.8 — fixed in 0.21.8
How to fix
Upgrade to a fixed version: backstage 1.54.1; Linuxfoundation Backstage/Plugin-Kubernetes-Backend 0.21.8. Check the vendor advisory for mitigations.
References
- https://github.com/backstage/backstage/commit/2d5d3e77d630455d6d48cfa8f31fd3c126fd6f29
- https://github.com/backstage/backstage/releases/tag/v1.54.1
- https://github.com/backstage/backstage/security/advisories/GHSA-r9ph-3637-55px
Get alerted when CVE-2026-106563 or the next vulnerability affects your stack