What’s Vulnerable › Vulnerabilities
CVE-2026-106564: ImageMagick: Heap Buffer Over-Write in EXR decoder
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-07 · updated 2026-10-22
- Weakness: CWE-122
Description
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to 7.1.2-32, a crafted EXR image can cause the EXR decoder to write beyond a heap buffer, causing the process to crash. This issue is fixed in version 7.1.2-32.
Affected products
- ImageMagick: before 7.1.2-32 — fixed in 7.1.2-32
How to fix
Upgrade to a fixed version: ImageMagick 7.1.2-32. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/commit/f7437ebafcd92d6959eca4086d80b150d52bdb7c
- https://github.com/ImageMagick/ImageMagick/releases/tag/7.1.2-32
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-54rx-5x9g-g465
Get alerted when CVE-2026-106564 or the next vulnerability affects your stack