What’s Vulnerable › Vulnerabilities
CVE-2026-106569: ImageMagick: Denial of service in ASE decoder because of missing security checks
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-07 · updated 2026-10-21
- Weakness: CWE-770
Description
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to 7.1.2-32, missing validation and resource checks in the ASE decoder allow a crafted ASE image to cause a crash or a long-running operation. This issue is fixed in version 7.1.2-32.
Affected products
- ImageMagick: before 7.1.2-32 — fixed in 7.1.2-32
How to fix
Upgrade to a fixed version: ImageMagick 7.1.2-32. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/commit/0691546106f4c7e8857da9f21a0e4a8f41915388
- https://github.com/ImageMagick/ImageMagick/commit/5ecd5b047cee7ccfe4e14a733a0755c7b2a90c7d
- https://github.com/ImageMagick/ImageMagick/releases/tag/7.1.2-32
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-gwj6-pm7x-3r63
Get alerted when CVE-2026-106569 or the next vulnerability affects your stack