What’s Vulnerable › Vulnerabilities
CVE-2026-106571: ImageMagick: Heap Buffer Over-Write in GetVirtualPixels api will result in a crash
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-07 · updated 2026-10-21
- Weakness: CWE-190
Description
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to 6.9.13-56 and 7.1.2-31, a crafted local call to the GetVirtualPixels API can trigger an integer calculation error and write beyond a heap buffer, crashing the server process. This issue is fixed in versions 6.9.13-56 and 7.1.2-31.
Affected products
- ImageMagick: before 6.9.13-56; from 7.0.0-0 before 7.1.2-31 — fixed in 6.9.13-56, 7.1.2-31
How to fix
Upgrade to a fixed version: ImageMagick 6.9.13-56, 7.1.2-31. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/commit/8f3a15e60b723bfe3e80bd1b5e4bee88397467f7
- https://github.com/ImageMagick/ImageMagick/releases/tag/7.1.2-31
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-jvjm-9f73-fhpq
- https://github.com/ImageMagick/ImageMagick6/commit/91f4ed74a1fd8326ade11a1153de110f22d89aa1
- https://github.com/ImageMagick/ImageMagick6/releases/tag/6.9.13-56
Get alerted when CVE-2026-106571 or the next vulnerability affects your stack