What’s Vulnerable › Vulnerabilities
CVE-2026-106577: ImageMagick: Code Injection in the postscript coders
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-07 · updated 2026-10-21
- Weakness: CWE-94
Description
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to 7.1.2-31 and 6.9.13-56, unescaped or untrimmed values can inject code into output generated by PostScript coders. This issue is fixed in versions 7.1.2-31 and 6.9.13-56.
Affected products
- ImageMagick: before 6.9.13-56; from 7.0.0-0 before 7.1.2-31 — fixed in 6.9.13-56, 7.1.2-31
How to fix
Upgrade to a fixed version: ImageMagick 6.9.13-56, 7.1.2-31. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/commit/2ba2edfd04a1ab3d45af4a0dc1e640dde7020192
- https://github.com/ImageMagick/ImageMagick/commit/78378cd623468760bee82a5930cb3011725916f8
- https://github.com/ImageMagick/ImageMagick/releases/tag/7.1.2-31
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-5rg6-j44q-q892
- https://github.com/ImageMagick/ImageMagick6/commit/879489740daa44dd72e9405b26c845e8aa3d2f53
- https://github.com/ImageMagick/ImageMagick6/commit/d5750d7309ef5a8cd561430d932a183e4168f484
- https://github.com/ImageMagick/ImageMagick6/releases/tag/6.9.13-56
Get alerted when CVE-2026-106577 or the next vulnerability affects your stack