What’s Vulnerable › Vulnerabilities
CVE-2026-106579: ImageMagick: Policy Bypass when using coder as the domain.
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-07 · updated 2026-10-21
- Weakness: CWE-551
Description
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to 7.1.2-31 and 6.9.13-56, a crafted image can bypass an ImageMagick security policy that uses coder as its domain, potentially allowing data prohibited by the policy to be read. This issue is fixed in versions 7.1.2-31 and 6.9.13-56.
Affected products
- ImageMagick: before 6.9.13-56; from 7.0.0-0 before 7.1.2-31 — fixed in 6.9.13-56, 7.1.2-31
How to fix
Upgrade to a fixed version: ImageMagick 6.9.13-56, 7.1.2-31. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/commit/82f373fedb3425c83a239103ab86f4fa86fd49ac
- https://github.com/ImageMagick/ImageMagick/commit/dcdbbf4278fab20a32a4ad80e64cb95c368ca8dd
- https://github.com/ImageMagick/ImageMagick/releases/tag/7.1.2-31
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-vcjj-32hg-qpx5
- https://github.com/ImageMagick/ImageMagick6/commit/ac85c8e0a319b1eaf4c3d05d326605f5bae723d6
- https://github.com/ImageMagick/ImageMagick6/commit/c54667bfe605ebdc17c23cb70a26dbe00b338222
- https://github.com/ImageMagick/ImageMagick6/releases/tag/6.9.13-56
Get alerted when CVE-2026-106579 or the next vulnerability affects your stack