What’s Vulnerable › Vulnerabilities
CVE-2026-106580: ImageMagick: Policy Bypass in CUT encoder
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-07 · updated 2026-10-21
- Weakness: CWE-284
Description
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to 7.1.2-31 and 6.9.13-56, a missing security-policy check in the CUT encoder allows a crafted local encoding operation to read data that policy should deny and can also cause a crash. This issue is fixed in versions 7.1.2-31 and 6.9.13-56.
Affected products
- ImageMagick: before 6.9.13-56; from 7.0.0-0 before 7.1.2-31 — fixed in 6.9.13-56, 7.1.2-31
How to fix
Upgrade to a fixed version: ImageMagick 6.9.13-56, 7.1.2-31. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/commit/768bdd0dbb9a9ad743b6a6e557126b788b325970
- https://github.com/ImageMagick/ImageMagick/releases/tag/7.1.2-31
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-r868-pmwh-fv2c
- https://github.com/ImageMagick/ImageMagick6/commit/ad178e41fce2afa6be2b91fb4e7f41c4c5448117
- https://github.com/ImageMagick/ImageMagick6/releases/tag/6.9.13-56
Get alerted when CVE-2026-106580 or the next vulnerability affects your stack