What’s Vulnerable › Vulnerabilities
CVE-2026-106582
- Severity: low (CVSS 3.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-06 · updated 2026-10-13
- Weakness: CWE-514
Description
In sshd and ssh in OpenSSH before 10.6, an LZ77 dictionary coder can be used even though this is contraindicated by the arXiv 2609.07709 "Crossing the Streams" findings.
Affected products
- OpenSSH: before 10.6 — fixed in 10.6
How to fix
Upgrade to a fixed version: OpenSSH 10.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-106582 or the next vulnerability affects your stack