What’s Vulnerable › Vulnerabilities
CVE-2026-106585
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-06 · updated 2026-10-15
- Weakness: CWE-409
Description
In sshd and ssh in OpenSSH before 10.6, there is no check for whether the maximum packet length is exceeded during decompression of highly compressed data.
Affected products
- OpenSSH: before 10.6 — fixed in 10.6
How to fix
Upgrade to a fixed version: OpenSSH 10.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-106585 or the next vulnerability affects your stack