What’s Vulnerable › Vulnerabilities
CVE-2026-1069: Uncontrolled Recursion in GitLab
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-11 · updated 2026-06-17
- Weakness: CWE-674
Description
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.9 before 18.9.2 that could have allowed an unauthenticated user to cause a denial of service by sending specially crafted GraphQL requests due to uncontrolled recursion under certain circumstances.
Affected products
- GitLab: from 18.9.0 before 18.9.2 — fixed in 18.9.2
How to fix
Upgrade to a fixed version: GitLab 18.9.2. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/releases/2026/03/11/patch-release-gitlab-18-9-2-released/
- https://gitlab.com/gitlab-org/gitlab/-/work_items/586474
- https://hackerone.com/reports/3483687
Get alerted when CVE-2026-1069 or the next vulnerability affects your stack