What’s Vulnerable › Vulnerabilities
CVE-2026-10712: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-25 · updated 2026-06-26
- Weakness: CWE-79
Description
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.10 before 18.11.6, 19.0 before 19.0.3, and 19.1 before 19.1.1 that under certain conditions could have allowed an unauthenticated user to execute arbitrary JavaScript in a user's browser session due to improper path validation under certain conditions.
Affected products
- GitLab: from 18.10.0 before 18.11.6; from 19.0.0 before 19.0.3; 19.1.0 — fixed in 18.11.6, 19.0.3
How to fix
Upgrade to a fixed version: GitLab 18.11.6, 19.0.3. Check the vendor advisory for mitigations.
References
- https://docs.gitlab.com/releases/patches/patch-release-gitlab-19-1-1-released/
- https://gitlab.com/gitlab-org/gitlab/-/work_items/601857
- https://hackerone.com/reports/3688717
Get alerted when CVE-2026-10712 or the next vulnerability affects your stack