What’s Vulnerable › Vulnerabilities
CVE-2026-107126: WP Booking System < 2.1.0.1 - Unauthenticated Stored XSS via X-Forwarded-For Header
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-14 · updated 2026-10-14
- Weakness: CWE-79
Description
The WP Booking System WordPress plugin before 2.1.0.1 does not sanitise and escape a client-controllable request value before storing it and later outputting it in an administration screen, allowing unauthenticated attackers to perform Stored Cross-Site Scripting attacks that execute in the session of an administrator who views the stored data.
Affected products
- WP Booking System: before 2.1.0.1 — fixed in 2.1.0.1
How to fix
Upgrade to a fixed version: WP Booking System 2.1.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-107126 or the next vulnerability affects your stack