What’s Vulnerable › Vulnerabilities
CVE-2026-107255: Restrict route by IP - Critical - Access bypass - SA-CONTRIB-2026-216
- Severity: unknown
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-30 · updated 2026-10-30
- Weakness: CWE-863
Description
Incorrect Authorization vulnerability in Drupal Restrict route by IP allows Forceful Browsing. This issue affects Restrict route by IP versions: from 0.0.0 to 1.3.1, from 2.0.0 to 2.0.1.
Affected products
- Drupal Restrict route by IP: before 1.3.1; from 2.0.0 before 2.0.1 — fixed in 1.3.1, 2.0.1
How to fix
Upgrade to a fixed version: Drupal Restrict route by IP 1.3.1, 2.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-107255 or the next vulnerability affects your stack