What’s Vulnerable › Vulnerabilities
CVE-2026-107298: msgpack5: Deeply nested input can exhaust the decoder stack
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-08 · updated 2026-10-09
- Weakness: CWE-674
Description
msgpack5 is a msgpack v5 implementation for node.js and the browser. Prior to 6.1.0, the array and map decoding paths have no nesting-depth limit, allowing an attacker who can provide MessagePack input to submit deeply nested containers that exhaust the JavaScript call stack and interrupt a process, worker, or request handler. This issue is fixed in version 6.1.0.
Affected products
- mcollina msgpack5: before 6.1.0
References
- https://github.com/mcollina/msgpack5/commit/1e2b5874e555dd7c99417f64788a03b0590bb102
- https://github.com/mcollina/msgpack5/releases/tag/v6.1.0
- https://github.com/mcollina/msgpack5/security/advisories/GHSA-24ch-f2g6-9hhh
Get alerted when CVE-2026-107298 or the next vulnerability affects your stack