What’s Vulnerable › Vulnerabilities
CVE-2026-107314: pgjdbc does not enforce requireAuth when the value excludes every authentication method
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-07 · updated 2026-10-08
- Weakness: CWE-636
Description
pgjdbc, the PostgreSQL JDBC Driver, versions 42.7.11 through 42.7.13 enforce no restriction when the requireAuth connection property excludes all six authentication methods the driver knows, for example requireAuth=!password,!md5,!gss,!sspi,!scram-sha-256,!none. The driver then accepts any method the server asks for, including cleartext password authentication. A value without a method in it, such as requireAuth=, (a single comma), is affected the same way. An attacker positioned between the application and its server can ask for cleartext password authentication and receive the database password. A positive list such as requireAuth=scram-sha-256, and a partial exclusion such as requireAuth=!password,!md5, are enforced correctly. The property has no default value, so a deployment that does not set it is not affected. 42.7.14 fixes the problem: such a connection is refused with SQLState 08004, and a value without a method in it is rejected as invalid.
Affected products
- pgjdbc: from 42.7.11 before 42.7.14 — fixed in 42.7.14
How to fix
Upgrade to a fixed version: pgjdbc 42.7.14. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-107314 or the next vulnerability affects your stack