What’s Vulnerable › Vulnerabilities
CVE-2026-107322: OS command injection in Amazon Agent Plugins for AWS databases-on-aws
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-08 · updated 2026-10-08
- Weakness: CWE-184
Description
An incomplete list of disallowed inputs in Amazon Agent Plugins for AWS databases-on-aws plugin before 1.7.1 might allow a remote unauthenticated actor to execute arbitrary operating system commands on the host running the helper via a crafted database command value introduced in the agent context. To remediate this issue, users should upgrade to databases-on-aws plugin version 1.7.1 or later and verify that the updated plugin is active in each environment where it is used.
Affected products
- aws databases-on-aws: before 1.7.1 — fixed in 1.7.1
How to fix
Upgrade to a fixed version: aws databases-on-aws 1.7.1. Check the vendor advisory for mitigations.
References
- https://aws.amazon.com/security/security-bulletins/2026-130-aws/
- https://github.com/awslabs/agent-plugins/commit/8b13a503746a4ebb0402b936645163224058bde3
- https://github.com/awslabs/agent-plugins/pull/232
Get alerted when CVE-2026-107322 or the next vulnerability affects your stack