What’s Vulnerable › Vulnerabilities
CVE-2026-10733: Improper Restriction of Rendered UI Layers or Frames in GitLab
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-11 · updated 2026-06-17
- Weakness: CWE-1021
Description
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 17.0 before 18.10.8, 18.11 before 18.11.5, and 19.0 before 19.0.2 that could have allowed an authenticated user to cause denial of service on the CI/CD Catalog page due to improper sanitization.
Affected products
- GitLab: from 17.0.0 before 18.10.8; from 18.11.0 before 18.11.5; from 19.0.0 before 19.0.2 — fixed in 18.10.8, 18.11.5, 19.0.2
How to fix
Upgrade to a fixed version: GitLab 18.10.8, 18.11.5, 19.0.2. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/releases/2026/06/10/patch-release-gitlab-19-0-2-released/
- https://gitlab.com/gitlab-org/gitlab/-/work_items/600446
Get alerted when CVE-2026-10733 or the next vulnerability affects your stack