What’s Vulnerable › Vulnerabilities
CVE-2026-10750: Royal MCP < 1.4.26 - Subscriber+ Insufficient Authorization in MCP Tools
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-01 · updated 2026-07-01
Description
The Royal MCP WordPress plugin before 1.4.26 does not perform capability checks on the majority of its MCP tools after token authentication, allowing authenticated users with a low-privileged role such as Subscriber to read private content, enumerate all users and their roles, and create, modify, or delete content owned by other users.
Affected products
- Royal MCP: before 1.4.26 — fixed in 1.4.26
How to fix
Upgrade to a fixed version: Royal MCP 1.4.26. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-10750 or the next vulnerability affects your stack