What’s Vulnerable › Vulnerabilities
CVE-2026-10754: Pega Platform versions 8.5.0 through 25.1.2 are affected by an improper validation of cryptographic signatures that may allow an attacker to bypass security controls.
- Severity: high (CVSS 8.6 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-10 · updated 2026-10-23
- Weakness: CWE-347
Description
Pega Platform versions 8.5.0 through 25.1.2 are affected by an improper validation of cryptographic signatures that may allow an attacker to bypass security controls.
Affected products
- Pegasystems Pega Infinity: from 8.5.0 before Infinity 25.1.3 — fixed in Infinity 25.1.3
How to fix
Upgrade to a fixed version: Pegasystems Pega Infinity Infinity 25.1.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-10754 or the next vulnerability affects your stack