What’s Vulnerable › Vulnerabilities
CVE-2026-107782: System Informer before 4.0.26241.138 Incorrect Authorization in phsvc ALPC Port
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-08 · updated 2026-10-14
- Weakness: CWE-863
Description
System Informer before 4.0.26241.138 contains an incorrect authorization vulnerability in the phsvc helper that allows local attackers to reach privileged APIs by connecting from any Authenticode-signed process. Attackers can load code into a Microsoft-signed host like rundll32.exe, connect to SiSvcApiPort, and call PhSvcApiCreateService to execute code as SYSTEM.
Affected products
- winsiderss System Informer: before 4.0.26241.138 — fixed in 4.0.26241.138
How to fix
Upgrade to a fixed version: winsiderss System Informer 4.0.26241.138. Check the vendor advisory for mitigations.
References
- https://github.com/winsiderss/systeminformer
- https://github.com/winsiderss/systeminformer/blob/v3.2.25011.2103/SystemInformer/phsvc/svcapiport.c#L196-L230
- https://github.com/winsiderss/systeminformer/commit/ce451a264a424f6f386b1615df651f8364aaeb9f
- https://github.com/winsiderss/systeminformer/releases/tag/v4.0.26241.138
- https://www.vulncheck.com/advisories/system-informer-before-4.0.26241.138-incorrect-authorization-in-phsvc-alpc-port
Get alerted when CVE-2026-107782 or the next vulnerability affects your stack