What’s Vulnerable › Vulnerabilities
CVE-2026-107806: Nginx UI: Authenticated Remote Code Execution via Backup Restore App Config Overwrite
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-10-09 · updated 2026-10-20
- Weakness: CWE-94
Description
Nginx UI is a web user interface for the Nginx web server. From 2.3.8 until 2.5.0, an authenticated administrator with an active secure session can submit attacker-controlled portable backup key material and a matching manifest to POST /api/restore. The restore flow trusts the supplied key, decrypts attacker-controlled contents, and replaces the live app.ini, including protected nginx command settings such as TestConfigCmd. Triggering POST /api/nginx/test then executes the restored command in the Nginx UI runtime context, affecting confidentiality, integrity, and availability. This issue is fixed in version 2.5.0.
Affected products
- 0xJacky nginx-ui: from 2.3.8 before 2.5.0 — fixed in 2.5.0
How to fix
Upgrade to a fixed version: 0xJacky nginx-ui 2.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/0xJacky/nginx-ui/commit/a467ed652591fc0cd1b466a1ec751b493faef9f7
- https://github.com/0xJacky/nginx-ui/releases/tag/v2.5.0
- https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-p393-cf76-4jmr
- https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-p393-cf76-4jmr
Get alerted when CVE-2026-107806 or the next vulnerability affects your stack