What’s Vulnerable › Vulnerabilities
CVE-2026-107812: Nginx UI: Self-upgrade runs an unsigned binary verified only by a same-origin digest → RCE via a compromised mirror or MITM
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-10-09 · updated 2026-10-20
- Weakness: CWE-494
Description
Nginx UI is a web user interface for the Nginx web server. From 2.0.0 until 2.5.0, the self-upgrade mechanism validates a downloaded binary only with a same-origin digest obtained from the same upgrade mirror. A compromised mirror or network attacker able to alter both responses can supply a malicious executable and matching digest. An operator-triggered upgrade is required, and the application installs and runs the attacker-controlled code in the Nginx UI process context on the next upgrade. This issue is fixed in version 2.5.0.
Affected products
- 0xJacky nginx-ui: from 2.0.0 before 2.5.0 — fixed in 2.5.0
How to fix
Upgrade to a fixed version: 0xJacky nginx-ui 2.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/0xJacky/nginx-ui/commit/580585516dd87a8b176bcdac258db70c3b64b7ec
- https://github.com/0xJacky/nginx-ui/releases/tag/v2.5.0
- https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-662p-52hx-cmh2
- https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-662p-52hx-cmh2
Get alerted when CVE-2026-107812 or the next vulnerability affects your stack