What’s Vulnerable › Vulnerabilities
CVE-2026-107813: Nginx UI: Incomplete fix of CVE-2026-84315 - the api/cluster router was not - wrapped in RequireSecureSession, so those sensitive mutations run without OTP step-up
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-09 · updated 2026-10-20
- Weakness: CWE-862
Description
Nginx UI is a web user interface for the Nginx web server. From 2.0.0 until 2.5.0, the api/cluster router exposes node and namespace mutation operations and cluster-wide Nginx reload or restart operations with AuthRequired but without RequireSecureSession. An authenticated OTP-enabled user possessing a stolen or persisted JWT can therefore perform node CRUD, read or replace node credentials, change namespaces, and invoke nodes/reload_nginx or nodes/restart_nginx without a fresh second-factor step-up. This issue is an incomplete fix for CVE-2026-84315 and is fixed in version 2.5.0.
Affected products
- 0xJacky nginx-ui: from 2.0.0 before 2.5.0 — fixed in 2.5.0
How to fix
Upgrade to a fixed version: 0xJacky nginx-ui 2.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/0xJacky/nginx-ui/commit/a3999bd78a3b97ab22e6b5e9fd478ac57598a954
- https://github.com/0xJacky/nginx-ui/releases/tag/v2.5.0
- https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-h246-wpgf-vmq5
Get alerted when CVE-2026-107813 or the next vulnerability affects your stack