What’s Vulnerable › Vulnerabilities
CVE-2026-107845: Contao: Cross-site scripting in the comments bundle
- Severity: critical (CVSS 9.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-09 · updated 2026-10-16
- Weakness: CWE-79
Description
Contao is an Open Source CMS. From version 4.0.0 until 5.3.50 and 5.7.12, an unauthenticated visitor can submit a comment whose email or website metadata is rendered without sufficient attribute and URL encoding by listComments() in comments-bundle/contao/dca/tl_comments.php. When a backend user opens the Comments module, attacker-controlled script can execute in the Contao backend origin under that user's session. Unpublished comments remain visible to moderators, so moderation does not prevent exposure. This issue is fixed in versions 5.3.50 and 5.7.12.
Affected products
- contao: from 4.0.0, < 5.3.50; from 5.4.0-RC1, < 5.7.12
References
- https://github.com/contao/contao/commit/22505d5f79bc1a7f52e2cba5fddf6007e1f0408a
- https://github.com/contao/contao/releases/tag/5.3.50
- https://github.com/contao/contao/releases/tag/5.7.12
- https://github.com/contao/contao/security/advisories/GHSA-628f-v4f6-p37r
Get alerted when CVE-2026-107845 or the next vulnerability affects your stack