What’s Vulnerable › Vulnerabilities
CVE-2026-107914
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-09 · updated 2026-10-14
- Weakness: CWE-459
Description
Backdrop CMS 1.34 before 1.34.5 and 1.35 before 1.35.1 doesn't sufficiently protect configuration exports when delivering a compressed archive. This vulnerability is mitigated by the fact that an export must have been previously requested by someone with the "Synchronize, import, and export configuration" permission. NOTE: CVE-2026-107914 refers to the vulnerability in which config.admin.inc does not ensure that a file_unmanaged_delete operation occurs. Therefore, many archives could persist: config.tar.gz, config_0.tar.gz, config_1.tar.gz, etc. There is a separate config.module issue that could allow remote access by an anonymous user, but only for the one filename config.tar.gz.
Affected products
- BackdropCMS Backdrop: from 1.34.0 before 1.34.5; from 1.35.0 before 1.35.1 — fixed in 1.34.5, 1.35.1
How to fix
Upgrade to a fixed version: BackdropCMS Backdrop 1.34.5, 1.35.1. Check the vendor advisory for mitigations.
References
- https://backdropcms.org/security/backdrop-sa-core-2026-006
- https://github.com/backdrop/backdrop/commit/1ae67061d9d487bb6cb3b8611191354052f34749
- https://github.com/backdrop/backdrop/commit/347c8e558254633205f431ce5c12321a7ae9248e
Get alerted when CVE-2026-107914 or the next vulnerability affects your stack