What’s Vulnerable › Vulnerabilities
CVE-2026-108066: WP 2FA < 4.2.0 - Admin+ Arbitrary User 2FA Removal via IDOR
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-14 · updated 2026-10-15
- Weakness: CWE-639
Description
The WP 2FA WordPress plugin before 4.2.0 does not perform an object-level capability check before removing a user's two-factor authentication configuration, allowing a site administrator on WordPress Multisite to remove the 2FA configuration of users outside their own site, including accounts they are not permitted to edit. On single-site installs an administrator can already manage all users, so this crosses a trust boundary only on Multisite.
Affected products
- WP 2FA: before 4.2.0 — fixed in 4.2.0
How to fix
Upgrade to a fixed version: WP 2FA 4.2.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-108066 or the next vulnerability affects your stack