What’s Vulnerable › Vulnerabilities

CVE-2026-108096: Improper authorization in query resolvers for SQL-backed models in AWS Amplify API Category

Description

Improper authorization in the query resolvers generated by @aws-amplify/graphql-index-transformer in AWS Amplify API Category before 3.1.2 might allow an authenticated remote user to read records owned by other users of the same application via crafted queries. This issue has been addressed in @aws-amplify/graphql-index-transformer 3.1.2 https://www.npmjs.com/package/@aws-amplify/graphql-index-transformer/v/3.1.2 (included in @aws-amplify/data-construct 1.17.4 https://www.npmjs.com/package/@aws-amplify/data-construct/v/1.17.4 and @aws-amplify/graphql-api-construct 1.21.4 https://www.npmjs.com/package/@aws-amplify/graphql-api-construct/v/1.21.4 ). We recommend upgrading to the latest version ensuring any forked or derivative code is patched to incorporate the new fixes and then redeploying their backend.

Affected products

How to fix

Upgrade to a fixed version: aws-amplify/data-construct 1.17.4; aws-amplify/graphql-api-construct 1.21.4; aws-amplify/graphql-index-transformer 3.1.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-108096 or the next vulnerability affects your stack