What’s Vulnerable › Vulnerabilities
CVE-2026-10821: Yoast SEO Premium < 27.6.1 - Author+ Arbitrary .htaccess Directive Injection to RCE
- Severity: medium (CVSS 6.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-02 · updated 2026-09-03
- Weakness: CWE-74
Description
The Yoast SEO Premium WordPress plugin before 27.6.1 does not sanitize control characters from redirect origins before writing them to the site's Apache configuration file when the file-based redirect mode is enabled, and the redirect-creation endpoint is reachable by users with only Author-level access. This allows such users to inject arbitrary newline-delimited Apache directives into the root .htaccess file. On Apache servers that honour PHP directives, the injection can be chained with the user's own media upload (a polyglot image carrying a PHP payload) and an auto_prepend_file directive to achieve Remote Code Execution.
Affected products
- Yoast SEO Premium: before 27.6.1 — fixed in 27.6.1
How to fix
Upgrade to a fixed version: Yoast SEO Premium 27.6.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/2ddd8362-7248-48de-aab9-74c70e7d5dd6/
- https://yoast.com/yoast-seo-premium-may-26-2026/
Get alerted when CVE-2026-10821 or the next vulnerability affects your stack