What’s Vulnerable › Vulnerabilities
CVE-2026-10827: Spectra (Ultimate Addons for Gutenberg) < 2.20.0 - Contributor+ Stored CSS Injection via Block Attributes
- Severity: low (CVSS 3.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-01 · updated 2026-08-26
- Weakness: CWE-345
Description
The Spectra Legacy WordPress plugin before 2.20.0 does not validate or escape several block style attributes before using them to build the CSS it outputs on the front end, allowing users with the Contributor role and above to inject arbitrary CSS into the pages that render the affected block. The injected styles are served to anonymous visitors of those pages and can force external resource loads, deface/redress the page, or exfiltrate data via CSS attribute selectors. JavaScript execution is not possible at this role (the script-tag breakout is removed by KSES), so the impact is limited to CSS injection.
Affected products
- Spectra Legacy: before 2.20.0 — fixed in 2.20.0
How to fix
Upgrade to a fixed version: Spectra Legacy 2.20.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-10827 or the next vulnerability affects your stack