What’s Vulnerable › Vulnerabilities
CVE-2026-108307: Tanium addressed a heap-based buffer overflow vulnerability in Index.
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-27 · updated 2026-10-28
- Weakness: CWE-122
Description
Tanium addressed a heap-based buffer overflow vulnerability in Index.
Affected products
- Tanium Endpoint Configuration Toolset Solution: from 1.51 before 1.51.60; from 1.59 before 1.59.50; from 1.71 before 1.71.25 — fixed in 1.51.60, 1.59.50, 1.71.25
- Tanium index-cx: from 3.9.520 before 3.9.520; from 3.11.443 before 3.11.443; from 3.14.921 before 3.14.921; from 3.14.917 before 3.14.917; from 3.15.2420 before 3.15.2420; from 3.16.984 before 3.16.984 — fixed in 3.9.520, 3.11.443, 3.14.921, 3.14.917, 3.15.2420, 3.16.984
How to fix
Upgrade to a fixed version: Tanium Endpoint Configuration Toolset Solution 1.51.60, 1.59.50, 1.71.25; Tanium index-cx 3.9.520, 3.11.443, 3.14.921, 3.14.917. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-108307 or the next vulnerability affects your stack