What’s Vulnerable › Vulnerabilities
CVE-2026-108574: BerriAI LiteLLM Spend Tracking spend_management_endpoints.py ui_view_session_spend_logs authorization
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-11 · updated 2026-10-13
- Weakness: CWE-285
Description
A flaw has been found in BerriAI LiteLLM up to 1.95.0. Affected by this issue is the function ui_view_session_spend_logs of the file litellm/proxy/spend_tracking/spend_management_endpoints.py of the component Spend Tracking. Executing a manipulation of the argument session_id can lead to authorization bypass. It is possible to launch the attack remotely. The exploit has been published and may be used. Upgrading to version 1.96.0 can resolve this issue. This patch is called 722d9ffa4f6c5ae15702ab9ab2c5f6bf1688308b. The affected component should be upgraded.
Affected products
- BerriAI litellm: 1.0, 1.1, 1.2, 1.3, 1.4, 1.5 (+90)
References
- https://github.com/BerriAI/litellm/
- https://github.com/BerriAI/litellm/commit/722d9ffa4f6c5ae15702ab9ab2c5f6bf1688308b
- https://github.com/BerriAI/litellm/releases/tag/v1.96.0
- https://vuldb.com/cve/CVE-2026-108574
- https://vuldb.com/submit/955441
- https://vuldb.com/vuln/416231
- https://vuldb.com/vuln/416231/cti
Get alerted when CVE-2026-108574 or the next vulnerability affects your stack