What’s Vulnerable › Vulnerabilities
CVE-2026-108598: Floci 1.1.0 before 2.2.0 RCE via API Gateway VTL Mapping Templates
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-10 · updated 2026-10-16
- Weakness: CWE-94
Description
Floci 1.1.0 before 2.2.0 contains a code injection vulnerability in VtlTemplateEngine that allows unauthenticated attackers to execute commands via unrestricted Velocity mapping templates. Attackers can create a REST API with a MOCK integration whose template uses $util reflection to reach Runtime or ProcessBuilder, executing OS commands in the Floci JVM.
Affected products
- floci-io floci: from 1.1.0 before 2.2.0 — fixed in 2.2.0
How to fix
Upgrade to a fixed version: floci-io floci 2.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/floci-io/floci
- https://github.com/floci-io/floci/blob/560b3e4aae61cea3ac7d4d51843bdffd0e3085fd/src/main/java/io/github/hectorvent/floci/services/apigateway/VtlTemplateEngine.java#L74-L114
- https://github.com/floci-io/floci/commit/144b90e6fa861a5ac882e99a090d503da01945c4
- https://github.com/floci-io/floci/releases/tag/2.2.0
- https://github.com/floci-io/floci/security/advisories/GHSA-3p4c-wp7w-mgjx
- https://github.com/ghostx-86/exploitarium/tree/main/floci-apigateway-vtl-rce-poc
- https://www.vulncheck.com/advisories/floci-1.1.0-before-2.2.0-rce-via-api-gateway-vtl-mapping-templates
Get alerted when CVE-2026-108598 or the next vulnerability affects your stack