What’s Vulnerable › Vulnerabilities
CVE-2026-108692: 1Panel-dev CordysCRM 1.9.0 before 1.9.2 Missing Authorization via /field/source Endpoints
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-11 · updated 2026-10-14
- Weakness: CWE-862
Description
1Panel-dev CordysCRM from 1.9.0 before 1.9.2 contains a missing authorization vulnerability in eight ModuleFieldController /field/source data-source endpoints lacking permission checks. Authenticated users denied module permission can page through organization-wide leads, contacts, quotations, contracts, payment plans, payment records, orders and invoices owned by other users.
Affected products
- 1Panel-dev CordysCRM: from 1.9.0 before 1.9.2 — fixed in 1.9.2
How to fix
Upgrade to a fixed version: 1Panel-dev CordysCRM 1.9.2. Check the vendor advisory for mitigations.
References
- https://github.com/1Panel-dev/CordysCRM/blob/a0ef69d31fd98c338199579353840f34ef679197/backend/crm/src/main/java/cn/cordys/common/service/DataScopeService.java#L100-L110
- https://github.com/1Panel-dev/CordysCRM/blob/a0ef69d31fd98c338199579353840f34ef679197/backend/crm/src/main/java/cn/cordys/crm/system/controller/ModuleFieldController.java#L133-L266
- https://github.com/1Panel-dev/CordysCRM/commit/a31fa16fb2dc86ab6b0fdc1ee58a204af424f38d
- https://github.com/AnkesKasty/cve-request-poc/blob/a7b6d1423555812d8efa26c91c5d0683164b31e5/CordysCRM/poc_field_source_family.py
- https://www.vulncheck.com/advisories/1panel-dev-cordyscrm-1.9.0-before-1.9.2-missing-authorization-via-field-source-endpoints
Get alerted when CVE-2026-108692 or the next vulnerability affects your stack