What’s Vulnerable › Vulnerabilities
CVE-2026-108953: mac-shell-mcp before 2.0.0 OS Command Injection via execute_command Arguments
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-16
- Weakness: CWE-78
Description
mac-shell-mcp before 2.0.0 contains an OS command injection vulnerability that allows MCP clients to bypass the command whitelist by injecting shell metacharacters into execute_command arguments. Attackers or malicious prompts can call a safe command such as pwd with arguments like ';' to run forbidden commands as the server user without approval.
Affected products
- cfdude mac-shell-mcp: before 2.0.0 — fixed in 2.0.0
How to fix
Upgrade to a fixed version: cfdude mac-shell-mcp 2.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/cfdude/mac-shell-mcp
- https://github.com/cfdude/mac-shell-mcp/blob/1c1708201abb7a18c83075e1bf933e7a92cbeb9f/src/services/command-service.ts#L257-L340
- https://github.com/cfdude/mac-shell-mcp/commit/932ce733cde07bb30b1f186303e6692dbb5d087a
- https://github.com/cfdude/mac-shell-mcp/issues/45
- https://www.vulncheck.com/advisories/mac-shell-mcp-before-2.0.0-os-command-injection-via-execute-command-arguments
Get alerted when CVE-2026-108953 or the next vulnerability affects your stack