What’s Vulnerable › Vulnerabilities
CVE-2026-108963
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-11 · updated 2026-10-13
- Weakness: CWE-88
Description
databasement before 1.8.2 allows remote code execution because it runs certain commands (e.g., mariadb-dump) with a database name that can be specified by any authenticated user. For example, --result-file=/app/public/index.php can write to index.php. In other words, quoting prevents OS command injection in mariadb-dump, but the argument injection alone is sufficient for code execution indirectly. NOTE: the project's composer.json file does not indicate an independently published databasement Composer package.
Affected products
- David-Crty databasement: from 1.0.0 before 1.8.2 — fixed in 1.8.2
How to fix
Upgrade to a fixed version: David-Crty databasement 1.8.2. Check the vendor advisory for mitigations.
References
- https://github.com/David-Crty/databasement/blob/bcee6f0e62796337aaac26961c41f7eb9578dd76/app/Services/Backup/Databases/MysqlDatabase.php#L22
- https://github.com/David-Crty/databasement/blob/bcee6f0e62796337aaac26961c41f7eb9578dd76/composer.json#L3
- https://github.com/David-Crty/databasement/commit/22258e3eac594e653f9d04a69d93e83923d61499
- https://github.com/David-Crty/databasement/commit/2d2761905594a2fa2c3d81d48a7c8b6a1784862c
- https://github.com/David-Crty/databasement/security/advisories/GHSA-hm57-pvxc-4pcm
Get alerted when CVE-2026-108963 or the next vulnerability affects your stack