What’s Vulnerable › Vulnerabilities
CVE-2026-108976
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-11 · updated 2026-10-16
- Weakness: CWE-184
Description
GNU Emacs before 31.2 (and TRAMP through 2.8.2) allows OS command injection via a filename because tramp-user-regexp has an incomplete list of disallowed inputs. NOTE: this issue exists because of an incomplete fix for CVE-2026-79992.
Affected products
- GNU Emacs: before 31.2 — fixed in 31.2
How to fix
Upgrade to a fixed version: GNU Emacs 31.2. Check the vendor advisory for mitigations.
References
- https://ftp.gnu.org/gnu/tramp/tramp-2.8.2.tar.gz
- https://www.openwall.com/lists/oss-security/2026/08/21/1
- https://www.openwall.com/lists/oss-security/2026/10/11/1
Get alerted when CVE-2026-108976 or the next vulnerability affects your stack