What’s Vulnerable › Vulnerabilities
CVE-2026-1090: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-11 · updated 2026-06-17
- Weakness: CWE-79
Description
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 10.6 before 18.7.6, 18.8 before 18.8.6, and 18.9 before 18.9.2 that could have allowed an authenticated user, when the `markdown_placeholders` feature flag was enabled, to inject JavaScript in a browser due to improper sanitization of placeholder content in markdown processing.
Affected products
- GitLab: from 10.6.0 before 18.7.6; from 18.8.0 before 18.8.6; from 18.9.0 before 18.9.2 — fixed in 18.7.6, 18.8.6, 18.9.2
How to fix
Upgrade to a fixed version: GitLab 18.7.6, 18.8.6, 18.9.2. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/releases/2026/03/11/patch-release-gitlab-18-9-2-released/
- https://gitlab.com/gitlab-org/gitlab/-/work_items/586478
- https://hackerone.com/reports/3502450
Get alerted when CVE-2026-1090 or the next vulnerability affects your stack