What’s Vulnerable › Vulnerabilities
CVE-2026-109147: WP Booking System < 2.1.0.3 - Reflected XSS via 'booking_id' Parameter
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-21
- Weakness: CWE-79
Description
The WP Booking System WordPress plugin before 2.1.0.3 does not validate and escape one of its parameters before reflecting it back in an admin page, leading to Reflected Cross-Site Scripting which could be used against high privilege users such as administrators.
Affected products
- WP Booking System: before 2.1.0.3 — fixed in 2.1.0.3
How to fix
Upgrade to a fixed version: WP Booking System 2.1.0.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-109147 or the next vulnerability affects your stack